Troubleshooting with Android ADB backup / restore

If the backup file is blank, and you use Android 4.X, you need Minimal ADB, version 1.0.0 works.